Delays in webhook event processing with connectors that utilize Virtual Webhooks

Incident Report for Apideck

Postmortem

Last week, we identified an issue in our system that led to delays in webhook event processing and manual sync triggers. A backlog of messages accumulated in our processing queue, causing high resource utilization and degraded performance.

Root Cause

The issue was traced to a bug in our pagination logic when processing data. This caused an unexpected loop, leading to repeated processing attempts and message buildup in our queue.

Resolution

We implemented a series of fixes, including:

  • Correcting the pagination logic to prevent looping

  • Optimizing message processing and error handling

  • Enhancing system monitoring to detect similar issues earlier

Impact

During the incident, some customers experienced delays in receiving webhook events and manually triggering syncs. We have since resolved the issue and taken steps to prevent recurrence.

Next Steps

We are implementing additional monitoring and safeguards to improve system resilience and ensure seamless webhook processing. We appreciate your patience and remain committed to maintaining a reliable experience.

Posted Mar 06, 2025 - 21:27 CET

Resolved

This incident has been resolved.
Posted Mar 05, 2025 - 09:23 CET

Investigating

We are currently investigating this issue.
Posted Mar 04, 2025 - 08:44 CET
This incident affected: Unify (Webhooks).