Request Logs: Incomplete Results

Incident Report for Apideck

Postmortem

Request Logging Service - Resolved

Incident Period: August 28, 2025, 2:00 PM GMT+2 to September 2, 2025, 12:30 AM GMT+2

Impact Summary

During this period, logging of incoming API requests to Unify was intermittent. While downstream connector requests (calls made to third-party services on your behalf) continued to be logged normally, some primary API requests made directly to Unify endpoints were not captured in our logging system.

What Was Affected

  • Intermittent logging of incoming requests to Unify API endpoints (e.g., /crm/contacts, /accounting/invoices)
  • Request logs available through the Unify dashboard and API may show incomplete request history for this period
  • Downstream connector activity (requests to Salesforce, HubSpot, Xero, etc.) remained fully logged throughout

What Was NOT Affected

  • API functionality - All API requests continued to process normally
  • Downstream connector logging - Complete visibility into third-party service interactions was maintained
  • Service reliability - No impact on API performance or availability
  • Billing accuracy - Usage tracking and billing calculations were unaffected

Resolution

The issue has been fully resolved as of approximately midnight September 2, 2025. All request logging is now functioning normally, with complete visibility into both incoming API requests and downstream connector activity.

Next Steps

If you require historical request data from the affected period, please contact our support team at support@apideck.com.

Posted Sep 02, 2025 - 09:58 CEST

Resolved

This incident has been resolved
Posted Sep 02, 2025 - 00:40 CEST

Monitoring

Fix released and we're monitoring results.
Posted Sep 02, 2025 - 00:28 CEST

Identified

The issue has been identified and fix is being implemented.
Posted Sep 01, 2025 - 23:52 CEST

Investigating

We're currently investigating a report issue where the log view in the admin is displaying an incomplete result set.
Posted Sep 01, 2025 - 21:41 CEST
This incident affected: Unify (Logs).